Descubra se seu processador Intel possui vulnerabilidade de firmware

A Intel assumiu neste post que há uma vulnerabilidade no Intel MEI e fez a liberação de uma ferramenta de detecção da versão do firmware do seu equipamento para que você descubra se seu processador Intel possui vulnerabilidade de firmware, confira como utilizar!

Veja esse trecho do post:

Descubra se seu processador Intel possui vulnerabilidade de firmware
Descubra se seu processador Intel possui vulnerabilidade de firmware

Se a versão do seu firmware se enquadrar em um deles, atualize o mais rápido possível!

Como rodar o Intel-SA-00086 Detection Tool no Linux?

Realize o download da ferramenta aqui no site da Intel. Clique no canto superior esquerdo SA00086_Linux.tar.gz:

Descubra se seu processador Intel possui vulnerabilidade de firmware
Descubra se seu processador Intel possui vulnerabilidade de firmware

E vamos para o terminal!

Acesse a pasta onde consta o arquivo baixado como root:

  • $ sudo su
  • $ cd /home/mateus/Downloads

Vamos extrair o programa dentro de um novo diretório:

  • $ mkdir Intel800 && tar xvzf SA00086_Linux.tar.gz -C Intel800
Descubra se seu processador Intel possui vulnerabilidade de firmware
Descubra se seu processador Intel possui vulnerabilidade de firmware

 

 Acesse a pasta que acabamos de extrair:

  • $ cd Intel800
  • $ ls
Descubra se seu processador Intel possui vulnerabilidade de firmware
Descubra se seu processador Intel possui vulnerabilidade de firmware

Veja que temos vários arquivos em Python, logo, precisamos do Python instalado.

Caso não tenha, instale alguma versão abaixo da Python 3, pois tentei executar com ele e havia erros de sintaxe.

Se seu Python default for menor que a versão 3, podes executar desta forma:

  • $ ./intel_sa00086.py

Caso o seu Python default seja mais recente que a versão 3 (como é meu caso), você pode executar desta forma:

  • $ python2.7 intel_sa00086.py
Descubra se seu processador Intel possui vulnerabilidade de firmware
Descubra se seu processador Intel possui vulnerabilidade de firmware

Felizmente, meu equipamento não se encontra dentro das versões vulneráveis.

Caso seu firmware esteja dentre as versões vulneráveis, acompanhe no site da Intel as atualizações. Também fique atento no site dos fabricantes como Dell, HP, Lenovo por alguma atualização.

 

Se tiver alguma dúvida ou sugestão de conteúdo, por favor, entre em contato aqui ou comente abaixo!